0
Answered

says mod_deflate not available

Im Robert Too 3 months ago in General WordPress updated 3 months ago 3

Hi, I ran the compatibility tests and it tells me a bunch of modules are not available, but they are installed. So why does it say they are not available ?

Hi Robert, thank you for contacting us!

The detection script in W3TC requires mod_php mode to detect if modules are available, and that mode is not available to the plugin if you are using PHP-FPM.  However this only means that W3TC cannot detect them, they are still available for use on your server.

For example, enable Gzip compression (which requires mod_deflate) check if Gzip compression is working by testing your website on GtMetrix or any other Gzip check tool. The reports from those services should indicate that Gzip was used to speed up your website, even though W3TC couldn't detect it in the compatibility check.

Please let us know if you have any additional questions for us!

I ran the compatibility tests in W3TC. A support person said it's because I am using php-fpm. I get that, so the question is then presumably that I cannot make use of W3TC cacheing for my wordpress site ?

Answered

Hi Robert, thank you for your question!

Which compatibility tests are you running that are not correctly detecting your modules?  Any additional screenshots or error messages that you can provide us will help our team determine where the problem might be coming from.

We also have our new BoldGrid Community forum directly through our support center where you can get help from our teams as well as other users.

I look forward to hearing back from you soon!