0
Answered

I'm using the WPForms to create the email form. I have Enable anti-spam honeypot checked, but mail still going to SPAM. suggestions?

Tica H 10 months ago updated 10 months ago 2

I'm using the Westview Theme.  Using WPForms ... Traditional email.  The mail is being delivered to recipient's SPAM folder.  how do I prevent this from happening?  THANKS 

Answer

Answer
Answered

Hello Tica,

Sorry for the problems with the mail going to spam. I would make sure that your emails are following the rules that allow it to not be classified as spam. Otherwise, you may need to check to see if your server or domain has been blacklisted. This would mean that emails coming from your server are automatically being blocked.  Typically, this will require that you contact your email host's support team in order to investigate the issue.

The honeypot option is used to spammers from hitting your forms.

If you have any further questions or comments, please let us know.

Kindest regards,

Arnel C.

Answer
Answered

Hello Tica,

Sorry for the problems with the mail going to spam. I would make sure that your emails are following the rules that allow it to not be classified as spam. Otherwise, you may need to check to see if your server or domain has been blacklisted. This would mean that emails coming from your server are automatically being blocked.  Typically, this will require that you contact your email host's support team in order to investigate the issue.

The honeypot option is used to spammers from hitting your forms.

If you have any further questions or comments, please let us know.

Kindest regards,

Arnel C.

Thank you.  I'll contact them.