0
Answered

Google Coverage issues

David A Mulholland 2 weeks ago updated by Jesse Owens (Community Manager) 2 weeks ago 1

Guys can you tell me what the problem is here as I got this email from Google?

Coverage issues detected on https://businessmoneymatters.co.uk/

To the owner of https://businessmoneymatters.co.uk/:

Search Console has identified that your site is affected by 1 Coverage issues:

Top Errors

Errors can prevent your page or feature from appearing in Search results. The following errors were found on your site:

Submitted URL marked ‘noindex’

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

This is what is says on the Google page so what do I do and why is this happening?

Submitted URL marked ‘noindex’First detected: 01/09/2019Status: ErrorLEARN MOREValidation startedStarted: 02/09/2019SEE DETAILSAffected pages104/06/201915/06/201926/06/201907/07/201919/07/201931/07/201911/08/201922/08/20193210Examples

URLLast crawled
https://businessmoneymatters.co.uk/sitemap.html


Answer

Answer
Answered

Hello David,

Thanks for the great question. Google will send you this message if you have submitted a sitemap that contains pages marked as "noindex" inside your Google Search console. 

There are two ways to resolve this, depending on your needs. You can either remove the "noindex" from the posts and pages it is mentioning, or you can remove those posts and pages from your sitemap, if the noindex directive was intentional.


Judging by the link you posted, it looks like you're using the popular plugin Google XML Sitemaps to generate your sitemap files. In order to exclude posts and pages from your sitemap, navigate to Settings -> XML Sitemaps and scroll down to Excluded Items. Here you can add a comma-separated list of the post ID's you need to exclude from your sitemap. 


Here are the instructions from the Plugin's developer on excluding items.

I hope this helps!

Answer
Answered

Hello David,

Thanks for the great question. Google will send you this message if you have submitted a sitemap that contains pages marked as "noindex" inside your Google Search console. 

There are two ways to resolve this, depending on your needs. You can either remove the "noindex" from the posts and pages it is mentioning, or you can remove those posts and pages from your sitemap, if the noindex directive was intentional.


Judging by the link you posted, it looks like you're using the popular plugin Google XML Sitemaps to generate your sitemap files. In order to exclude posts and pages from your sitemap, navigate to Settings -> XML Sitemaps and scroll down to Excluded Items. Here you can add a comma-separated list of the post ID's you need to exclude from your sitemap. 


Here are the instructions from the Plugin's developer on excluding items.

I hope this helps!