0
Answered

Why am I not getting emails from my contact form?

Penny.Astrology 1 month ago updated 4 weeks ago 3

WordPress settings has my correct email address and I have verified this. My contact forms were all automatically set to send the notification to amin_email... everything I find on Google says that this should be sending my contact form submissions to my email... what is going on?

Answer

Answer
Answered

Hello,

Thanks for the excellent question, this is actually a really common issue for WordPress users on a shared hosting platform.

When WordPress sends mail, whether that's using your contact form or, for example, resetting your Admin password, by default it uses the server's PHP Mail system. This is important because lots of spammers also use PHP Mail, which makes a lot of email systems see these unauthenticated emails as Spam. Check your spam folder, but it's also possible that your email provider didn't even let the emails get that far.

One experiment I always recommend before taking your next step is to go through the "Forgot your Password" process to see if you can receive that email. If you do get that email, something is wrong with your actual forms. If you don't, you can reasonably conclude that your website Email is not working.

The most common way to fix this is to use an SMTP plugin, such as WPForms WP Mail SMTP, which will actually let you set up your website to log into your email account and send mail as you. WPForms also has a really good email troubleshooting tutorial on troubleshooting this issue.

Your hosting provider will also be able to check your email delivery logs to determine the precise cause of any issues, so you can also contact them to be sure.

I hope this helps! 

BAD, I'M UNSATISFIED
Satisfaction mark by Penny.Astrology 4 weeks ago

Hi-
Thanks for the clarification. 

Judging by what your support team said, 

...saying that it was my email server that had blocked the contact form message.

That sounds exactly what I would expect if your email provider was rejecting the messages as Spam. I recommend proceeding with the SMTP Plugin, such as WPForms WP Mail SMTP.

Thanks Jesse. Oddly enough, I am getting my reset password emails, so I would think that the WP form I am using is the issue... however, when I contacted InMotion support, their representative asked me what my email address was, checked the outgoing email code, and then sent my a copy of the code, saying that it was my email server that had blocked the contact form message.

So I really have not been able to narrow down the problem. The settings for the contact form notifications look ok on my end... it should be going to my email.

I sent an email to Outlook's support team but have not gotten a response yet.

Answer
Answered

Hello,

Thanks for the excellent question, this is actually a really common issue for WordPress users on a shared hosting platform.

When WordPress sends mail, whether that's using your contact form or, for example, resetting your Admin password, by default it uses the server's PHP Mail system. This is important because lots of spammers also use PHP Mail, which makes a lot of email systems see these unauthenticated emails as Spam. Check your spam folder, but it's also possible that your email provider didn't even let the emails get that far.

One experiment I always recommend before taking your next step is to go through the "Forgot your Password" process to see if you can receive that email. If you do get that email, something is wrong with your actual forms. If you don't, you can reasonably conclude that your website Email is not working.

The most common way to fix this is to use an SMTP plugin, such as WPForms WP Mail SMTP, which will actually let you set up your website to log into your email account and send mail as you. WPForms also has a really good email troubleshooting tutorial on troubleshooting this issue.

Your hosting provider will also be able to check your email delivery logs to determine the precise cause of any issues, so you can also contact them to be sure.

I hope this helps!