0
Under review

boldgrid inspirations plugin activation-wordpress

efi 6 months ago updated by Jesse Owens (Community Manager) 6 months ago 4

I have activated a  ecommerce gem theme and I changed it with best ecommerce theme.My hosting provider is inmotion hosting which provides Boldgrid connection.Boldgrid connect plugin is activated. When I try to activate boldgrid inspirations plugin Wordpress gave an error ''There has been a critical error on your website. Please check your site admin email inbox for instructions." . The error exactly is:

An error of type E_ERROR was caused in line 165 of the file /home/n1c9585/public_html/wp-content/plugins/boldgrid-inspirations/vendor/boldgrid/boldgrid-inspirations-premium/src/Premium/Attribution.php. Error message: Uncaught Error: Call to a member function get_configs() on null in /home/n1c9585/public_html/wp-content/plugins/boldgrid-inspirations/vendor/boldgrid/boldgrid-inspirations-premium/src/Premium/Attribution.php:165 Stack trace: #0 /home/n1c9585/public_html/wp-includes/class-wp-hook.php(287): Boldgrid\Inspirations\Premium\Attribution->addControls(Array) #1 /home/n1c9585/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #2 /home/n1c9585/public_html/wp-content/themes/di-responsive/inc/kirki/kirki/deprecated/filters.php(29): apply_filters('kirki/fields', Array) #3 /home/n1c9585/public_html/wp-includes/class-wp-hook.php(287): {closure}(Array) #4 /home/n1c9585/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array) #5 /home/n1c9585/public_html/wp-content/themes/di-responsive/inc/kirki/kirki/core/class-kirki-init.php(243): apply_filters('kirki_fields', Array) #6 /home/n1c9585/public_html/wp-content/themes/di-responsive/inc/kirki/kirki/core/class-kirki-init.php(121): Kir

Answer

Answer

Hello Efi-
It looks like this may have been a conflict with the Theme Di Responsive. I've filed a bug report for our developers to review this issue.

In the meantime, you should try to disable the BoldGrid Inspirations plugin. Here are instructions for doing so via FTP or your host's file manager or using the command line.

Answer

Hello Efi-
It looks like this may have been a conflict with the Theme Di Responsive. I've filed a bug report for our developers to review this issue.

In the meantime, you should try to disable the BoldGrid Inspirations plugin. Here are instructions for doing so via FTP or your host's file manager or using the command line.

Hello Jesse,

Thanks for your reply. So I am waiting for an update of you for the conflict solution or is it needed to check the bug report for developers?

Hi Efi-

We'll release an update for this issue as soon as we can. Since you're using a non-BoldGrid theme, you probably don't need Inspirations enabled. Check out this video to see what to expect when you disable BoldGrid Inspirations: