Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #40950
    Mi Lee

    My website is

    After I upgrading the php to 7.4, the site went blank when I activated w3 total cache plugin

    w3 total cache is not compliant with php 7.4 ?

    What is your recommendataion?

    Thank you.

    Marko Vasiljevic


    Thank you for reaching out and I am sorry about the issue you are experiencing.
    W3 Total Cache is compatible with the latest PHP 8 and this means that it’s also compatible with any previous versions.
    I can see that you are using some other caching solution.
    I would recommend completely removing and re-install W3 Total Cache. Make sure that the other caching plugin is completely removed as well.
    1. Check .htaccess File (make a backup)
    W3TC will create many directives in the .htaccess file to control the caching behavior. Each section will start and end with comments like “#BEGIN W3TC Page Cache core” and “#END W3TC Page Cache core”.
    Ensure that no residual entries are leftover in your .htaccess file after deleting the plugin.
    2. Delete wp-content files and folders
    – cache folder
    – w3tc-config folder
    – object-cache.php (if exists)
    – advanced-cache.php (if exists)
    – db.php (if exists)
    – upgrade folder
    – delete w3-total-cache folder in wp-content/plugins/ (if exists)
    3. Delete Cached Files from CDN (if using CDN)
    Besides deleting all the relevant files, if you use CDN then ensure to purge the cached content from your CDN. This is necessary when you enabled minify option in W3TC settings. You should delete the minified and combined scripts and CSS files from your CDN server to avoid the site breaking on the browser.
    4. Go to your wp dashboard and re-install W3 Total Cache
    I hope this helps!

    Mi Lee

    Thank you Marko for your guidance.
    I was able to re-install according to your instruction.
    However after I set up general setting, it went to blank again.
    The strange thing is there is preview option in General setting, so after I enabled each option, I previewed, and it looked okay. But after deploy the website is blank.
    Page Cache enabled
    Minify enabled
    Database cache enabled
    Browser cache enabled.

    Below 2 options I set enabled then disabled again, because I thought these were the cause.
    Object cache -> enabled then I disabled
    Lazy Load Images -> on then I did off

    However the website is still blank.

    I appreciate if you can guide me what I did wrong.

    Thank you.

    Marko Vasiljevic

    Thank you for your feedback.
    I’ve checked your website and I am seeing it loading just fine.
    After inspecting the website I can see that the following options are enabled:

    Performance optimized by W3 Total Cache. Learn more:
    Object Caching 0/306 objects using disk
    Page Caching using disk: enhanced 
    Lazy Loading
    Minified using disk
    Served from: @ 2021-08-09 10:28:35 by W3 Total Cache


Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘After upgrading php to 7.4, my website went blank with w3 total cache.’ is closed to new replies.