Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #44184
    Mark Firehammer
    Guest

    This website is deployed on a load balanced, server on AWS Lightsail. we configured The plug-in and were given the alert that the plug-in wasn’t able to update wp-config and were given the required change, which we successfully added to the file.
    Below is the recommended change.
    /** Enable W3 Total Cache */
    define(‘WP_CACHE’, true); // Added by W3 Total Cache

    After clearing all caches, we still get the error that The already completed change is still required. Any ideas about what we might do to get around this? Here’s a look at it for crystal clarity.
    Thank you in advance for any insights that could be helpful.

    #44205
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    Thank you for your question and for using W3 Total Cache.
    There are no know issues with a server on AWS Lightsail. Once W3 Total Cache is installed and activated, in order for caching to work (‘WP_CACHE’, true); needs to be defined in wp-config.php.
    W3 Total cache automatically adds

    /** Enable W3 Total Cache */
    define(‘WP_CACHE’, true); // Added by W3 Total Cache

    at the top of the wp-config.php file just below the <?PHP tag. So if you added the constant manually, please make sure it’s added just after opening <?PHP tag.
    W3 Total Cache needs write permissions for some files and folders, like wp-config.php, .htaccess, /wp-content/ etc.
    By default, the permissions for wp-config.php should be 644 which allows W3 Total Cache to write. Can you please double-check the permissions for that file?

    Let me know if you have any other questions.
    Thanks!

    #44209
    Mark Firehammer
    Guest

    Thank you for your response Marko. the additional information you provided about the placement of that addition to the WP config file successfully got us past that error. Might be good idea to have that, detail to the message within plug-in!
    I’m now getting a message that is a little contradictory, it’s easiest to understtand if I just showed you. Take a look.

    • This reply was modified 9 months, 3 weeks ago by Marko Vasiljevic.
    • This reply was modified 9 months, 3 weeks ago by Jesse Owens. Reason: Fix loom video link
    #44232
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    Thank you for yoru feedback and I am glad I was able to help!

    The notification about CDN via Amazon being currently disabled means that the CDN is not enabled in Performance>CDN. You do not have to enable it before setting up but you need to choose the CDN type method which as I see you already did. So the notification will be gone once the CDN function is enabled.
    The first thing that you should do is to remove https:// from the AWS URL in the Replace hostname with the field so it should look like this for example: d2z677rcp2alwr.cloudfront.net

    As for permissions, the wording there is a bit strange. So what you did is basically deny permissions by setting the last two to “On”. I hope this makes sense.

    Please let me know if this helps!

    Thanks!

    #44244
    Mark Firehammer
    Guest

    thanks for your response. in your second paragraph

    The notification about CDN via Amazon being currently disabled means that the CDN is not enabled in Performance>CDN. You do not have to enable it before setting up but you need to choose the CDN type method which as I see you already did. So the notification will be gone once the CDN function is enabled.

    the bolded section, kind of implies that there is a switch or button to enable the CDN, once the type method is chosen. But I find no switch or button actually dedicated to enabling CDN in your plug-in dashboard. Here’s how I went about looking for it: https://www.loom.com/share/884583d209d04025835d242e1e60f1e7
    The end of the screen cast asks question about .htaccess Needing to be writable, Pointing out that the file doesn’t exist in lightsail Where you would expect. It has been moved to a config file for security.

    I followed your instruction and removed the HTTPS:/? from the hostname field.
    regarding your comment on permissions. You did not instruct, to turn the to permissions that were on, to off, but I think I can assume from your wording that is what you intended. I went ahead and turned those two off, cleared the cache and tested again. But did not get a different result.
    Interesting to note, we got our settings from this blog post: https://destinmoulton.com/blog/2020/configure-s3-bucket-cloudfront-and-iam-policy-for-w3-total-cache/

    Any other insights before we give up?
    Regards,
    Mark

    #44245
    Mark Firehammer
    Guest

    Here’s a resource on .htaccess in Lightsail with bitnami stacks.
    https://docs.bitnami.com/aws/infrastructure/lamp/administration/use-htaccess/
    Thinking the absence of the file may be the issue.

    #44247
    Mark Firehammer
    Guest

    a final question that will maybe make this easier. We see the you offer a configuration service foor $150. I would be willing to do that if you can guarantee that it will actually work with the technologies we have in place. if you’vve alrready done this on another Bitnami WordPress stack on Lightsail servers site then by all means we’d be happy to pay for the service. And then upgradee to Pro. Possible?

    #44292
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    Thank you for your feedback.
    First of all, I apologize for the lack of specific instructions. I’ve made a mistake stating that the “Enable” checkbox is in Performance>CDN.
    As you can see in the image below, I was referring to Performane>General settings, CDN sub-box. There, you can enable the CDN feature:

    I hope this clarifies where the CDN should be enabled and once again I am sorry about the mistake I made.
    I’ve checked some of our installations and in the image below you can see the Permissions that need to be set. So you should set all Block all public access to off:

    I’ve then tried to do everything from the scratch.

    1 – In Performance>Generall settings, scroll down to CDN, enable the CDN, and select the CDN Type: Amazon Cloudfront over S3 and save all settings.
    2 – In Performance>CDN>Configuration Objects, I’ve added the Access key ID: and Secret key: and saved all settings.
    3 – I’ve then created a new bucket by adding the bucket name and clicking the Create a new bucket with distribution, I’ve got the notification that the Bucket was successfully created. Once the bucket was created the Replace site’s hostname with: was automatically populated.
    4 – I’ve then tested the S3 Upload And Cloudfront distribution. At first, it failed with the notification “Error: Distribution status is not Deployed, but “InProgress”.” so I’ve tried again after a minute and the test was successful.

    I was able to do the same thing 3 times in a row.

    As for the .htaccess file. Yes, you are correct Bitnami moved the configuration of .htaccess to the main application configuration files.
    In the link, you shared there is also a video that explains how to move the .htaccess rules created by W3 Total Cache to the main configuration file. You can also check the Rewrite Rules (based on active settings) in Performance>Install.

    I hope this helps and please let me know if you have any other questions.
    As for the configuration service, yes we can do all this for you if you chose the Performance Audit service.
    Thank you!

    #44300
    Mark Firehammer
    Guest

    Excellent, thank you for the more thorough details. Were not having the same success but it has to be due to the .htaccess Situation and needs to be remedied first. So can you answer my question about your configuration service for $150? Here’s the question again from yesterday
    “We see the you offer a configuration service foor $150. I would be willing to do that if you can guarantee that it will actually work with the technologies we have in place. if you’vve alrready done this on another Bitnami WordPress stack on Lightsail servers site then by all means we’d be happy to pay for the service. And then upgradee to Pro. Possible?”

    #44321
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    You are most welcome and Thank you for your reply.

    I would be willing to do that if you can guarantee that it will actually work with the technologies we have in place.

    I cannot guarantee anything because I cannot guarantee anything. Simply because I need to have access to everything in order to be able to check and confirm.
    However, let me make some more tests and I’ll get back to you soon with more information.
    I’ve seen the W3TC + Bitnami configurations that are working excellent, I just need to investigate more why the AWS test fails.
    Please give me some time to check some more things and I’ll get back to you once I can share more details.

    Thanks!

    #44322
    Mark Firehammer
    Guest

    Let me restate the guarantee request. If you fail to get the config to work I’d get my $150 back. If you can’t do that I’d go with aws iq help.
    As for why I’d start with the. Htaccwss issue. Your plug-in requires it so it seems that is the missing piece.

    #44467
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    Sorry for the late reply I was trying to replicate the problem.
    We will do our best to set everything up. There is absolutely no reason why this can’t work, we just need to dig a little bit deeper to find out what may be causing this.
    So you can go forward and purchase the Performance Audit solution so we can schedule this.
    Thanks!

    #44470
    Mark Firehammer
    Guest

    We’ve already hired an AWS IQ expert to do this configuration for us. It’s much easier to give them access to everything AWS that it is to give it to you. Thank you though. I think we’ll be set up by the end of the day.

    #44469
    Mark Firehammer
    Guest

    Thanks for your reply. For now we’ve gone with an AWS IQ expert, because it’s very easy to give them full access to all the different AWS components. In fact we found somebody who’s already done this, exact needed configuration of your plug-in on our set up. So I believe were going to be fine.

    #44473
    Marko Vasiljevic
    Keymaster

    Hello Mark,

    Thank you for the information.
    Please let us know if you have any other questions and share any information that may be helpful for setups such as yours.
    Thanks!

Viewing 15 posts - 1 through 15 (of 15 total)
  • The topic ‘Any known issues with Amazon Lightsail hosting and W3 Total Cache?’ is closed to new replies.