Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #31681
    Vinny Paglia

    Hello, I’ve recently uncovered a problem when W3TC works in conjunction with TranslatePress. For the translated versions of my website, Polish in particular, the woo-commerce Cart# module, as well as social icons provided within the divi theme, cannot properly assimilate. The problem does not persist if the W3TC plugin is deactivated

    Link to Cart module example:

    Link to Social Icon Example:

    For the social icon, here is the HTML before translation: class=”icon et_pb_with_border”
    Social icons, here is the HTML after translations (where it appears broken): et_pb_with_border’title=

    How can I go in and fix this? I’m an amateur, at best, when it comes to this kind of stuff…

    Joseph W

    Hi Vinny,

    It sounds like there might be a conflict with TranslatePress and the HTML minifier used in W3 Total Cache that is breaking the HTML for those icons, and deactivating HTML minification could help you get those icons displaying as expected.

    You can locate the HTML minification configuration by navigating to Performance > Minify in your WordPress dashboard and then look for the HTML & XML section on that settings page. Disable HTML minify and click the Save Settings and Purge Caches button to ensure that the newest configuration is loaded for your website.

    I hope that this helps you get your icons working and please let us know if there is anything else that we can do to help!


    yeah that has not worked unfortunately. I was informed by support to do the following:

    It appears to be an issue (Conflict) with the Translatepress plugin. to be honest this is the first time I am seeing this kind of issue. The interesting thing is that we cannot find the module (setting) that might be responsible for this in W3 Total Cache and may narrow down where the conflict is.

    SO what you can tr in this case is:

    Disable all other plugins except W3 Total Cache (Leaving of course Translatepress and Woo active) and see if the issue persists. if the issue is gone, re-enable the plugins one by one and see which one might be causing this. If the issue is still there with all the plugins disable go with the next step:

    Add the URL to Performance>Page Cache>Aliases> Additional home URLs: and of course enable the Cache alias hostnames: Make sure to save all settings and purge the cache after the URL is added and Cache alias hostnames: enabled.

    As a last resort, you can try replacing the wp-content/plugins/w3-total-cache/Extension_Wpml_Plugin_Admin.php file with the one attached in this email. Make sure to back up the original one. In the one attached, I’ve made some code changes for the WPML support multilanguage plugin.

    Joseph W

    Hi Vinny,

    Did you have any luck with the troubleshooting steps provided by our dedicated W3 Total Cache Support team? We are curious what might be causing this problem and we would really appreciate it if you could let us know if any of those techniques worked!

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘Broken HTML’ is closed to new replies.