Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #49190
    Rebecca
    Guest

    Hi I have just installed w3 total caching plugin and have followed the instructions as per setup documentation. I am using the flatsome theme. When I actually load the UX builder it stays on a loading loop. Please advise on this issue
    hope to hear from you soon.
    thanks

    #49206
    Marko Vasiljevic
    Keymaster

    Hello Rebecca,

    Thank you for reaching out and I am happy to assist you with this.
    You have not shared the website URL so I am not sure which settings are enabled in W3 Total Cache.
    However, most likely the problem is with Minify and the fact that Minify is enabled for logged-in users.
    This means that the files responsible for the builder are minified (and they should not be) and therefore the UXbuilder is loading in the loop.
    Go to Performance>Minify, and in the General box, enable the checkbox “Disable minify for logged-in users”, save all settings and purge the cache and let me know if this helps!
    Please check the screenshot below. Thanks!

    #49209
    Rebecca
    Guest

    Hi Marko,

    Thanks for your prompt reply. Does the enabling of

    Go to Performance>Minify, and in the General box, enable the checkbox “Disable minify for logged-in users”, save all settings and purge the cache and let me know if this helps!

    mean that even customers who are logged in will have the minify disabled? or is this restricted to admin users only.

    I have also enclosed our website details

    #49240
    Rebecca
    Guest

    Hi Marko,
    We went through the setup and chose what was recommended. Please do let us know if you have any recommendations on how to improve our caching. Especially on mobile, as we are trialing w3 cache as it was a recommended plugin by our Flatsome theme.

    Any help would be much appreciated.
    Thanks

    #49272
    Rebecca
    Guest

    Also do I need to do this setting in page cache:

    Bypass WooCommerce Cookies
    To bypass page caching for pages that have WooCommerce-specific cookies, go to W3TC’s “Page Cache” settings, scroll down to “Rejected Cookies”, and add the four items below.

    woocommerce_items_in_cart
    woocommerce_cart_hash
    wp_woocommerce_session_
    wordpress_logged_in

    recommended here kinsta recommendations

    #49313
    Marko Vasiljevic
    Keymaster

    Hello Rebecca,

    Thank you for the information and I am glad that the UXbuilder Loading On Loop problem is resolved.
    As for the Woocommerce question, As I’ve mentioned before, it’s not recommended to cache pages for logged-in users, especially for e-commerce websites, simply to avoid caching any sensitive information about the visitors.
    Adding those WC cookies to the Reject Cookies list will ensure that the pages containing those cookies are not cached.
    I hope this helps!

    #49364
    Rebecca
    Guest

    Hi Marko,
    Thank you for replying will set those options into Page cache. With regards to disabling minify for logged in users will it cause the site to load slower? As we have customers that access their account and store for their gift registry and slowing down wont be ideal while they are adding their products.
    Can we leave this off and switch it on when admins need to edit the site?

    #49392
    Marko Vasiljevic
    Keymaster

    Hello Rebecca,

    Naturally, the pages are faster when the CSS and JS are minified.
    To answer your question, yes, you can leave that option disabled and enable it when editing the website.
    Thanks!

    #49481
    Rebecca
    Guest

    I also need some help with mobile optimization. I am not sure how to go about it. Could you kindly point me with the documentation as you can see our speed scores on pagespeed insights.

    I was testing manual minify mode. However, when when I switch back to auto even after removing any additional css/js added in manual and use the default settings. The website doesnt load the images properly anymore unless i disable minify javascript. Any reason for this?

    #49583
    Marko Vasiljevic
    Keymaster

    Hello Rebecca,

    Thank you for yoru feedback.
    You have not shared the website URL so unfortunately I cannot check or test the website.
    Please switch the Minify to Manual save all settings and purge the cache and check the website.
    If you are having issues, disable the settings in Performance>minify one by one (HTML minify, JS minify, CSS minify) and see which one might be causing the issue.
    Make sure to save all settings and purge the cache after each option is disabled.

    Thanks!

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘UXbuilder loading on loop when W3 cache is activated.’ is closed to new replies.