Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #26258
    Jonathon Weeks

    So, If I install the W3 Total Cache plugin and enable page caching, it absolutely kills the functionality of the WooCommerce API.  This is a necessary API for the site.   I have tried adding /wc/v3 and various forms of that to stop it from caching, but nothing is working.  Can you tell me what’s going on or how to get around this?   I have seen other posts from a year ago where another had this issue, but it doesn’t appear to have any resolution other than adding what I did, but it isn’t working for me.   Thank you.

    Jesse Owens

    Hi Jonathon-

    You mentioned that you’re using /wc/v3 in the Never cache the following pages section, I’d like to verify that you’re using the correct regular expression:


    I’d also like to verify that you’ve input this into the “Never Cache” sections for both Page Cache and Database Cache.

    Another possible way to fix this is to find out which user agent your API calls are using, and add that string to the Rejected User Agents field in your Page Cache settings.

    If you’re still having trouble, are you able to provide the response JSON here so we can see if there’s any additional information contained there?

Viewing 2 posts - 1 through 2 (of 2 total)
  • The topic ‘W3 Total Cache Disables WooCommerce API’ is closed to new replies.