Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #28614
    Barbara Rykal

    Been working with to speed up site and followed many guidelines to set expires headers. Even after the boxes checked, showing 0 score in add expires headers performance.
    What should we do to enable what has been selected to set header expiration?

    Joseph W

    Hi Barbara!

    I ran a GTMetrix report on your website and took a look at the URLs flagged in the Adds Expires Headers section of that report. There are a few URLs listed there, specifically ones from Google Fonts, Google Analytics and Facebook, that all reference external resources and unfortunately those resources cannot be controlled by your settings in W3 Total Cache.

    However there are a few coming from StackPath that should be respecting your Expires Headers settings:

    Navigate in your WordPress dashboard to Performance > Browser Cache > JS & CSS to verify that the Expires Headers and Cache Control configurations are enabled. Then check the Set Expires Header setting for JS and CSS files are set to the default duration of 31536000 seconds.

    If those settings are correct and you are still getting the Adds Expires Headers warning in the GTMetrix report then you also want to double check StackPath settings. The StackPath settings can be found in your WordPress dashboard under Performance > Dashboard > Sites > CDN > Client Browser Policy.

    One last thing you can do is check the .htaccess file for you website to see if there are any duplicate rules for the Expires Headers and Cache Control settings.

    I hope that these troubleshooting steps help you get your files cached as expected and please let us know if you have any other questions for us!

Viewing 2 posts - 1 through 2 (of 2 total)
  • The topic ‘W3TC set header expiration and not working’ is closed to new replies.