Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #54811
    Tanguy MEREL
    Guest

    Hi there,
    We just updated our test environment with your new plugin version (2.2.1), which now seems to automatically enable the “Total Cache Image Service” feature.
    Just beware it’s might lead to issues.

    We use WPML to translate our content, and especially the WPML Media Translation to translate our images.
    Here (at that point, I didn’t even notice that new image feature), I tried to translate a new product, to which I had an image associated as featued image. This image was freshly uploaded, while creating the product.
    Once this product is published in the original language, I went to media translation to upload a image translation for this media. As I usually do, so that when I translate a content to which this original image is associated, it automatically inherits the image translation.
    Then I went back to my product, and translated its content.
    Unfortunatelyn, I realised that the translated image didn’t appear : I was still seeing the same image as in the original language.
    After some searching, it seems that, as soon as its published, the webp version becomes the new official image for the product, as if it’s a totally different medial thant the original one I uploaded and translated.
    In the end, the WebP image had a dedicated line in the media translation. Which shouldn’t be the case, so that it remains an alternate image to the original one.

    Finally, I solved the issue by reverting the images and disabling the extension.

    #54819
    Marko Vasiljevic
    Keymaster

    Hello,

    Thank you for reaching out and for a detailed explanation of the problem you are facing.
    By default, the Auto-convert image after the upload is enabled in the W3 Total Cache Image Servce feature.
    Most of the users do not want to bother and just because of that the option Auto-convert is always enabled.
    You can disable this in Performance>Extensions>Image Service. Click on the Settings link and select the Disabled radio button in the Configuration area:

    Once the images are translated, you can manually convert all images or a single image in the Media library.
    I hope this helps!

    Thanks!

    #54820
    Marko Vasiljevic
    Keymaster

    Hello,

    Thank you for reaching out and for a detailed explanation of the problem you are facing.
    By default, the Auto-convert image after the upload is enabled in the W3 Total Cache Image Servce feature.
    Most of the users do not want to bother and just because of that the option Auto-convert is always enabled.
    You can disable this in Performance>Extensions>Image Service. Click on the Settings link and select the Disabled radio button in the Configuration area:

    Once the images are translated, you can manually convert all images or a single image in the Media library.
    I hope this helps!

    Thanks!

    #54833
    Tanguy MEREL
    Guest

    Hi,
    Thanks for your detailed reply, although I thing I already figured out what you explained through the documentation.

    While people might not want to bother, as you explained, I writed to point out the fact that;- the behavior you provide doesn’t work smoothly with the WPML Media Translation tool.- activating the functionality by default, without notice, might actually make things more complicated/messy for those who don’t have advanced knowledge, especially when working with WPML.

    Indeed, Activation WebP image processing through W3TC with WPML enabled will result:
    – In WebP images duplications, visible separately from the Media Translation Tool, so that it now 2 images (jpg/png/… and WebP) declinations, and sets of equal meta data (title, alt, …). From a content management perspective, it might quickly turn as a nightmare. to maintain
    – Not to mention frontend output possible issues related to the way images are delivered.

    We’ll simply disable it.
    Best regards,

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘WebP image service’ is closed to new replies.