0
se.rose (anonymous) JohnPaul B edited answer

I selected the form I wanted to configure the email address for, but the emails still go to my personal email rather than my business email. Followed these instructions, but can’t figure out what’s troubleshooting: https://www.boldgrid.com/support/getting-to-know-boldgrid/customize-wpforms-form-settings/