+1
Under review

Backups Fail

petrus 2 years ago updated by support (Support) 7 months ago 7

host: Dreamhost

hosting plan: shared hosting

PHP 7.3 FastCGI 

Wordpress latest

Total Siteupkeep latest

Server specs:  https://i.imgur.com/MGL7Pmc.png

Backups keep failing using SystemZip or PclZip , though sometimes work.  seem to work OK with ZipArchive. 

On another WordPress install an exact copy of the first, with the same host, different server.   Backups run flawlessly with SystemZip.  

what gives?

Only error I see in the siteupkeep log is: (for a succesful backup) 

[2020-03-29 00:16:43 UTC] Memory usage - limit / current / peak memory usage: 1024M / 67137720 (64.03 MB) / 92566632 (88 MB)
[2020-03-29 00:16:43 UTC] PHP shutdown - Error found: Array
(
[type] => 2
[message] => Use of undefined constant SECURE_AUTH_KEY - assumed 'SECURE_AUTH_KEY' (this will throw an Error in a future version of PHP)
[file] => /home/<user>/<my_domain>/wp-content/plugins/boldgrid-backup/admin/class-boldgrid-backup-admin-crypt.php
[line] => 43
)

This is the log for a failed backup:

[2020-03-28 23:57:22 UTC] PHP Version: 7.3.12
[2020-03-28 23:57:22 UTC] WordPress Version: 5.3.2
[2020-03-28 23:57:22 UTC] Total Upkeep version: 1.13.2
[2020-03-28 23:57:22 UTC] Backup process initialized.
[2020-03-28 23:57:22 UTC] Starting dump of database...
[2020-03-28 23:57:22 UTC] Memory usage - limit / current / peak memory usage: 1024M / 51479376 (49.09 MB) / 51843528 (49 MB)
[2020-03-28 23:57:22 UTC] Dump of database complete! $status = 1
[2020-03-28 23:57:22 UTC] Memory usage - limit / current / peak memory usage: 1024M / 51484864 (49.10 MB) / 52573712 (50 MB)
[2020-03-28 23:58:10 UTC] Database dump file added to file list: /home/<user>/boldgrid_backup/<my_domain>_or_3.20200328-235722.sql / 2110854 (2.01 MB)
[2020-03-28 23:58:10 UTC] Starting archiving of files. Chosen compressor: system_zip
[2020-03-28 23:58:10 UTC] Memory usage - limit / current / peak memory usage: 1024M / 66845176 (63.75 MB) / 68358912 (65 MB)
[2020-03-28 23:58:10 UTC] Starting to create list of files to include in zip.
[2020-03-28 23:58:10 UTC] Memory usage - limit / current / peak memory usage: 1024M / 66836184 (63.74 MB) / 68358912 (65 MB)
[2020-03-28 23:58:10 UTC] Finished creating list of files to include in zip.
[2020-03-28 23:58:10 UTC] Memory usage - limit / current / peak memory usage: 1024M / 70296288 (67.04 MB) / 72323808 (69 MB)
[2020-03-28 23:58:10 UTC] Starting to close the zip file.
[2020-03-28 23:58:10 UTC] Memory usage - limit / current / peak memory usage: 1024M / 66840248 (63.74 MB) / 72323808 (69 MB)

UPDATE:   its actually failing with ZipArchive too.  so failing across the board.  

UPDATE:  Set up a vanilla on-click install on Dreamhost same server, same settings using Boldgrid.  although the backups ran ok some of the time,  they still fail quite often. Mind you, this is unchanged vanilla install! 

Under review

Hi petrus,

I'm very sorry to hear your backups are not completing successfully. You mentioned that you're hosting with DreamHost. Recently, we've been troubleshooting with their support team, and we found some system settings of theirs that should resolve the issue. Please see https://www.boldgrid.com/support/total-upkeep/dreamhost-without-fastcgi/

I hope this helps, and if it doesn't, please do get back to us.

Thanks!

- Joseph

Yes turning off FastCGI does seem to help. Is FastCGI not better for speed etc. It's also the recommended default on Dreamhost.   updraftplus backup plugin seems to have no issues with this, I think because they break up the backup into separate zip files and thereby circumvent the limitations of most shared hosting/server environments.  Maybe something for site upkeep to consider as most people will not understand why their backups are failing on Dreamhost and will maybe ditch the plugin altogether. I almost did to replace it with  UpdraftPlus.  

Also,  what it does not explain is why on my shared starter hosting with Dreamhost I have no issues with site upkeep and am using FastCGI!  While on my unlimited shared environment I do have issues.  

Hi Petrus,

I am glad to hear that disabling FastCGI was able to fix the problem with generating backups on your website.  Unfortunately we do not have an explanation why some accounts are able to generate backups when it is enabled and others do not, but our developers are working with the DreamHost team to get to the bottom of this and determine a better fix.

Your idea of chunking the backup data into smaller files is a solution that we are considering and, as you pointed out, will allow us to mitigate the resource restrictions the are usually placed on shared hosting accounts.  Hopefully our team can use your idea to make our backups run more smoothly in shared environments and thank you again for helping us improve Total Upkeep!

This problem still exists. The current Dreamhost advice is to "optimize" my website so that the backup file size is smaller and timeouts do not occur while the backup is being performed. Either that or turn off FastCGI. Both of these are not really solutions since (a) I can't just cut down my site content to make backups faster (that is the ultimately stupid tail-wagging-the-dog suggestion), and (b) I use other plugins and features that require FastCGI. 

Seeing that this hasn't been resolved in a YEAR, it looks like I will be switching to another backup solution, probably UpdraftPlus, which I use in some other sites without any such issues. That is really a shame because Dreamhost includes Total Upkeep as a standard, supported solution. But what benefit is that if it fails on a normal-sized site using default settings?

Thank you for contacting us. I completely understand the frustrations with using the current iteration of Total Upkeep and I am sorry that our team has not  yet been able to find a more reasonable fix for getting backups to work as expected within DreamHost's FastCGI configuration. I hope that you are able to find a backup solution that provides you with the usability that you need and if you ever have any questions for us please do not hesitate to ask!